apache2 and gitlab issue

I have installed gitlab-ctl on my ubuntu 16.04 and after that I was not able to access my default localhost, where I have bunch of local websites I work on, I was triggered with gitlab username/password in order to access it. As I don't need it, I removed it, but if I try to access http://localhost, I'm getting this issue:

dial unix /var/opt/gitlab/gitlab-rails/sockets/gitlab.socket: connect: connection refused 

I figured out that my default Apache configs are overridden, thus I had the idea to change the port to access local www folder, but it is not really working. My new port is 90, I changed the config in /etc/apache2/sites-enabled/000-default, changed port in /etc/apache2/ports.config, restarted apache, and if I enter in browser http://localhost:90, I can see apache is working.

But I have quite few of custom virtual hosts set on my machine, I changed the port there as well, but they are not accessible. I tried to change settings in /etc/hosts, but is not working as expected.

For example I have sites like myweb.local and settings:

/etc/hosts:

127.0.0.1   myweb.local 

/etc/apache2/sites-enabled/myweb.conf

<VirtualHost *:90>     ServerAdmin [email protected]     ServerName myweb.local     DocumentRoot /var/www/myweb     <Directory />         Options FollowSymLinks         AllowOverride All     </Directory>     <Directory /var/www/myweb/ >         Options Indexes FollowSymLinks MultiViews         AllowOverride All         Order allow,deny         allow from all     </Directory>      ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/     <Directory "/usr/lib/cgi-bin">         AllowOverride None         Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch         Order allow,deny         Allow from all     </Directory>    ....      Alias /doc/ "/usr/share/doc/"     <Directory "/usr/share/doc/">         Options Indexes MultiViews FollowSymLinks         AllowOverride None         Order deny,allow         Deny from all         Allow from 127.0.0.0/255.0.0.0 ::1/128     </Directory>  </VirtualHost> 

I cannot acccess it on url: http://myweb.local, adding a port is working ok, ie:

http://myweb.local:90

How can I make this work or how could I get my old settings back? Thanks in advance.

Replay

Category: ubuntu Time: 2016-07-31 Views: 5

Related post

iOS development

Android development

Python development

JAVA development

Development language

PHP development

Ruby development

search

Front-end development

Database

development tools

Open Platform

Javascript development

.NET development

cloud computing

server

Copyright (C) avrocks.com, All Rights Reserved.

processed in 0.119 (s). 12 q(s)