failed to add i915_bpo component master (-19) (Sound problems on Ubuntu 14.04)

I do not get any outputs in the audio menu.

[email protected]:~$ lspci 00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07) 00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07) 00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31) 00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31) 00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31) 00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31) 00:1b.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Root Port #17 (rev f1) 00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1) 00:1c.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1) 00:1c.5 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #6 (rev f1) 00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1) 00:1d.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #13 (rev f1) 00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31) 00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31) 00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31) 00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31) 00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31) 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290] (rev 80) 01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii HDMI Audio 04:00.0 Ethernet controller: Intel Corporation I211 Gigabit Network Connection (rev 03) 05:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a) [email protected]:~$ dmesg | grep snd [    3.012232] snd_hda_intel 0000:01:00.1: Handle VGA-switcheroo audio client [    3.012234] snd_hda_intel 0000:01:00.1: Force to non-snoop mode [    3.030765] snd_hda_intel 0000:00:1f.3: failed to add i915_bpo component master (-19) 

I am trying to use the onboard audio chip. I think the onboard audio chip is the one which failed to load something, but I cannot find anything helpful belonging to this problem.

[Update 30.07.2016 18:40] After applying this patch: http://askubuntu.com/a/677401/574495 from a question with a simmilar problem in now get more sound devices and with the more errors with dmesg | grep snd:

[email protected]:~$ dmesg | grep snd [    2.969244] snd_hda_core: module verification failed: signature and/or  required key missing - tainting kernel [    2.975974] snd_hda_intel 0000:00:1f.3: Probing card using HDA DKMS, version 0.201606221847~ubuntu14.04.1 [    2.976125] snd_hda_intel 0000:01:00.1: Probing card using HDA DKMS, version 0.201606221847~ubuntu14.04.1 [    2.976154] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client [    2.976155] snd_hda_intel 0000:01:00.1: Force to non-snoop mode [    2.993022] snd_hda_codec_realtek hdaudioC0D0: ALC1150: SKU not ready     0x00000000 [    2.993582] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1150: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line [    2.993584] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0) [    2.993585] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0) [    2.993586] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0 [    2.993587] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x11/0x1e [    2.993587] snd_hda_codec_realtek hdaudioC0D0:    inputs: [    2.993588] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19 [    2.993589] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18 [    2.993590] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a [    3.011538] snd_hda_intel 0000:00:1f.3: control 0:0:0:SPDIF Phantom Jack:0 is already present [    3.011647] snd_hda_codec_realtek: probe of hdaudioC0D0 failed with error -16 [    3.011805] snd_hda_codec_realtek hdaudioC0D0: ALC1150: SKU not ready 0x00000000 [    3.012320] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1150: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line [    3.012322] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0) [    3.012323] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0) [    3.012323] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0 [    3.012324] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x11/0x1e [    3.012325] snd_hda_codec_realtek hdaudioC0D0:    inputs: [    3.012326] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19 [    3.012327] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18 [    3.012331] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a [    3.024792] snd_hda_intel 0000:00:1f.3: control 0:0:0:SPDIF Phantom Jack:0 is already present [    3.024841] snd_hda_codec_realtek: probe of hdaudioC0D0 failed with error -16 [    3.026424] snd_hda_codec_realtek hdaudioC0D0: ALC1150: SKU not ready 0x00000000 [    3.027142] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1150: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line [    3.027144] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0) [    3.027145] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0) [    3.027146] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0 [    3.027147] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x11/0x1e [    3.027147] snd_hda_codec_realtek hdaudioC0D0:    inputs: [    3.027148] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19 [    3.027149] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18 [    3.027150] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a [    3.040116] snd_hda_intel 0000:00:1f.3: control 0:0:0:SPDIF Phantom  Jack:0 is already present [    3.040182] snd_hda_codec_realtek: probe of hdaudioC0D0 failed with error -16 [    3.043232] snd_hda_codec_generic hdaudioC0D0: autoconfig for Generic: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line [    3.043238] snd_hda_codec_generic hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0) [    3.043239] snd_hda_codec_generic hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0) [    3.043240] snd_hda_codec_generic hdaudioC0D0:    mono: mono_out=0x0 [    3.043240] snd_hda_codec_generic hdaudioC0D0:    dig-out=0x11/0x1e [    3.043241] snd_hda_codec_generic hdaudioC0D0:    inputs: [    3.043242] snd_hda_codec_generic hdaudioC0D0:      Front Mic=0x19 [    3.043246] snd_hda_codec_generic hdaudioC0D0:      Rear Mic=0x18 [    3.043247] snd_hda_codec_generic hdaudioC0D0:      Line=0x1a [    3.052935] snd_hda_intel 0000:00:1f.3: control 0:0:0:SPDIF Phantom Jack:0 is already present [    3.052992] snd_hda_codec_generic: probe of hdaudioC0D0 failed with error -16 

Thanks for your help.

Replay

Category: 14.04 Time: 2016-07-30 Views: 0

Related post

iOS development

Android development

Python development

JAVA development

Development language

PHP development

Ruby development

search

Front-end development

Database

development tools

Open Platform

Javascript development

.NET development

cloud computing

server

Copyright (C) avrocks.com, All Rights Reserved.

processed in 0.321 (s). 12 q(s)