FTP works fine inside network, stuck at "waiting for welcome message" from outside [on hold]

At the office, we have a small network with a NAS with build-in FTP. We have recently moved, and I have been tasked to check if it is possible to get the FTP up and running.

I have managed to get the FTP up and running, and I can access it within our own network. When I try to access from home, I keep getting the message (using filezilla):

Connection established, waiting for welcome message... Connection timed out after 20 seconds of inactivity Could not connect to server

The setup: Router: Linksys WRT1900AC with port forwarding activated (Port 21, both TCP and UDP, see image)

NAS: Qnap TS-1079 Pro with FTP server activated

Switch: Linksys LGS318 (with no special setup as far as I know)

Things I have tried: Disable the Router firewall and filters Made a port range forward for 50000-51000 (and adjusted FTP servers passive FTP port range) Tried from more than one machine, over a period on 2-3 days, rebooted all the equipment

Is there anything obvious I'm missing? Also if something need clarification/screenshots/logs etc.

FTP works fine inside network, stuck at "waiting for welcome message" from outside [on hold]

Replay

Category: router Time: 2016-07-28 Views: 0
Tags: router

Related post

iOS development

Android development

Python development

JAVA development

Development language

PHP development

Ruby development

search

Front-end development

Database

development tools

Open Platform

Javascript development

.NET development

cloud computing

server

Copyright (C) avrocks.com, All Rights Reserved.

processed in 3.326 (s). 13 q(s)