Installing g++ on RHEL

I'm running Redhat Enterprise 6.7, and am currently running g++ version 4.4.7

I need to upgrade my g++, I tried following the method located here:

https://gist.github.com/stephenturner/e3bc5cfacc2dc67eca8b

I'm having trouble with the first step:

sudo rpm --import http://ftp.scientificlinux.org/linux/scientific/5x/x86_64/RPM-GPG-KEYs/RPM-GPG-KEY-cern 

After I run this, it returns

key 1 not an armored public key. 

I cannot figure out how to get past this error. Does anyone know what I need to do in order to resolve this?

Replay

Category: rhel Time: 2016-07-28 Views: 3

Related post

  • Installing gcc on rhel 6.1 2011-11-28

    GCC doesnt seem to be installed on my Rhel 6.1 machine. Also, when i did: sudo yum install gcc It barfed: Updating Red Hat repositories. Setting up Install Process No package gcc available. Error: Nothing to do The same command works fine on rhel 5.5

  • How to install cpp in RHEL 6.3? 2013-03-31

    I want to install gcc in RHEL 6.3, but it has cpp dependencies. So I go to cpp rpm download page, but it has no rpm for 6.3 version: Is there any other way to install cpp in RHEL 6.3?

  • Installing R on RHEL 7 2014-11-17

    I'm trying to install R on RHEL 7. I'm using epel-release-7-2.noarch.rpm and resolved many dependencies (one by one by manual .rpm installation) but at the end of the dependency resolution I got these errors: --> Finished Dependency Resolution Error:

  • Not able to install GIT on RHEL 7.1 2015-12-21

    I am trying to install git on rhel 7.1 using rpm. and i am getting below errors. [[email protected] Desktop]# rpm -ivh git-1.8.3.1-4.el7.x86_64.rpm warning: git-1.8.3.1-4.el7.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY error: Fail

  • How Do I Install LAMP on RHEL 64 bit Including Mcrypt? 2010-06-22

    Does anyone know of a good way to install LAMP on an RHEL 64 bit server which includes mcrypt? I went the manual route, and libmcrypt was not found even though it had been installed. I've tried every posted way on several forums with no success. I tr

  • Single CD install of a RHEL-like distribution? 2010-11-24

    Can someone suggest a RHEL-like distribution that can install from a single CD? I am looking for a distribution where services are started from /etc/init.d, environment variables are set from scripts in /etc/profile.d and so-on (meaning that Ubuntu d

  • Install wine on RHEL with Yum 2011-01-10

    I'm trying to install Wine on Red Hat Enterprise Linux using Yum, but it's not in the RHEL repository. How can I install RHEL via Yum? I'm pretty sure there may be other repositories out there somewhere which have a RHEL compatible binary (maybe Cent

  • Install postgresql on RHEL 5.6 2011-05-10

    When I try to run yum install postgresql I get the following error message: Transaction Check Error: file /usr/lib64/libecpg.so.6.1 from install of postgresql-libs-8.4.4-2PGDG.el5.x86_64 conflicts with file from package postgresql84-libs-8.4.7-1.el5_

  • How to install Ruby on RHEL 5.3 2011-06-15

    I am trying to install the latest Ruby on RHEL 5.3 with the following: [[email protected] logs]# yum install ruby-full Repository engineering-update is listed more than once in the configuration Repository engineering-install is listed more than once in th

  • trouble installing packages in RHEL 5.3 2012-02-08

    I'm trying to install rabbitvcs, a subversion GUI tool. http://wiki.rabbitvcs.org/wiki/install/fedora. [[email protected] conf]# yum install nautilus-python pysvn python-configobj python-devel dbus-python python-dulwich meld Setting up Install Process Parsing

  • How to install TortoiseHG on RHEL 5.3 from source? 2012-05-04

    I have been trying to install TortoiseHG with the yum command on my RedHat system and have been struggling. I thought perhaps I should install it from the source. I used the instructions here and here. However, it still didn't work. I am afraid that

  • Troubles installing mod_ssl on RHEL 5 2012-07-04

    [[email protected] ~]# yum install mod_ssl Loaded plugins: security Setting up Install Process No package mod_ssl available. Nothing to do This my yum repo list: Loaded plugins: security repo id repo name status rpmforge RHEL 5Server - RPMforge.net - da

  • How do I install WINE in RHEL 6.3? 2012-09-20

    I'm a beginner in Linux and I'm having a problem installing wine I'm using RHEL 6.3 and when I use yum install wine it keeps giving me this Blockquote Error: Package: wine-core-1.4.1-1.el6.i686 (epel) Requires: libxml2.so.2(LIBXML2_2.7.3) Error: Pack

  • My yum repository able to search packages, but not able to install it in RHEL? 2012-09-30

    I set up yum from dvd. Following is the containts of my .repo file: [dvd] name=Red Hat Enterprise Linux Installation DVD baseurl=file:///media/dvd enabled=0. I'm able to search packages. However while installation I'm getting below error: [[email protected]

  • How can I install git on RHEL 6? 2012-10-01

    I'm trying to install Git on a RHEL6 development server, I have experience with Ubuntu but this is my first time working with RHEL (I'm a developer trying to fill in for a recently departed Linux Sysadmin). I've set up two additional repos (EPEL and

  • Installing Tomcat6 on RHEL 6.4 2013-02-08

    I am missing some packages which Tomcat depends on. But whatever dependency I try to resolve, it all comes down to java-gcj-compat missing which I cannot find on the DVD. Note that I don't have an internet connection on the server so yum is not an op

  • Installing Multitail on RHEL 5.3 2013-07-29

    I'm trying to install Multitail on a RHEL 5.3 machine, but get the following error as the root user. Should this be accessible from one of the default RPM repositories or do I need to add a new repository or update an existing repository perhaps? 18:

  • How to install pulse during RHEL 5.9 install 2013-08-08

    I am desperately trying to install pulse on a rhel5.9 machine. I have tried googling all over but all I get are instruction on how to configure pulse/piranha on an already installed box. I have seen that rhel 6.x allows a user to chose load balancing

  • Installing openssl on RHEL 6.2 2013-10-23

    Trying to install openssl-devel on RHEL 6.2. yum install openssl-devel And i am getting this error: --> Finished Dependency Resolution Error: Package: glibc-2.12-1.47.el6.i686 (rhel62) Requires: glibc-common = 2.12-1.47.el6 Removing: glibc-common-2.1

  • install g++ on RHEL 6 2013-11-23

    This question already has an answer here: How do I install g++ on RHEL6? 1 answer I'm trying to install g++ (with gcc already installed) on my Red Hat Enterprise Linux 6. I've tried the following: $ yum install g++ $ yum install c++ $ yum install gcc

iOS development

Android development

Python development

JAVA development

Development language

PHP development

Ruby development

search

Front-end development

Database

development tools

Open Platform

Javascript development

.NET development

cloud computing

server

Copyright (C) avrocks.com, All Rights Reserved.

processed in 0.604 (s). 13 q(s)