No tables found after running Expdp and Impdp in Oracle 12c

I am trying to export a schema which only contains one table with one row on it. It has a table called "product" and resides in a tablespace called "tbs_data". Here's the expdp command I ran which completed successfully.

expdp dbauser/[email protected] schemas=myschema directory=my_data_pump_directory dumpfile=myschema_exp.dmp logfile=myschema_exp.log

When I ran the impdp, it complained about the "myschema" missing.

impdp dbauser/[email protected] schemas=myschema directory=my_data_pump_directory dumpfile=myschema_exp.dmp logfile=myschema_exp.log

So I created this user/schema manually and re-ran the impdp command. It completed successfully. However when I logged in as "myschema", I didn't see the product table. Also, from what I have been reading, the Impdp command was supposed to re-create the target user/schema when you run Impdp.

Could someone let me know what I am msising or how to resolve this?

Thanks

Replay

First, make sure that the table has been actually exported into the dump file. You can do it by searching the following text line in the log file:

exported "..."."product" ... rows

If there is no such line in the log file, try to find an error message explaining why the export failed. Second, review the log file of impdp (I suggest you to use another name for it, for example ). It should contain the following text line:

imported "..."."product" X out of Y rows

Again, if there is no such text in the log file, try to find an error message explaining why the import failed.

If the problem persists, you may want to try OraDump-to-Oracle tool that automates import Oracle dump files to Oracle server.

You're right. I don't even see the "imported ..." line in the log and I don't see any error either. Strange! Here's the actual log...

;;; Export: Release 12.1.0.2.0 - Production on Fri Jul 29 14:22:46 2016

Copyright (c) 1982, 2014, Oracle and/or its affiliates. All rights reserved. ;;; Connected to: Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production With the Partitioning, OLAP, Advanced Analytics and Real Application Testing options Starting "dbauser"."SYS_EXPORT_SCHEMA_01": dbauser/********@oradev schemas=myschema directory=my_data_pump_directory dumpfile=myschema_exp.dmp logfile=myschema_exp.log Estimate in progress using BLOCKS method... Total estimation using BLOCKS method: 0 KB Processing object type SCHEMA_EXPORT/DEFAULT_ROLE Processing object type SCHEMA_EXPORT/PRE_SCHEMA/PROCACT_SCHEMA Processing object type SCHEMA_EXPORT/STATISTICS/MARKER Master table "dbauser"."SYS_EXPORT_SCHEMA_01" successfully loaded/unloaded



Dump file set for dbauser.SYS_EXPORT_SCHEMA_01 is: C:\APP\ORACLE\ADMIN\ORADEV\DPDUMP\myschema_EXP.DMP Job "dbauser"."SYS_EXPORT_SCHEMA_01" successfully completed at Fri Jul 29 14:22:54 2016 elapsed 0 00:00:07

I am still investigating my problem and have been reading various posts all day today on the web but haven't figured it out yet. Any idea where I might need to look?

Category: oracle 11g r2 Time: 2016-07-29 Views: 0

Related post

iOS development

Android development

Python development

JAVA development

Development language

PHP development

Ruby development

search

Front-end development

Database

development tools

Open Platform

Javascript development

.NET development

cloud computing

server

Copyright (C) avrocks.com, All Rights Reserved.

processed in 0.139 (s). 12 q(s)