Problems installing gcc-6 /g++-6 on Linux Mint 17.1

So I am trying to put gcc-6/g++-6 on Linux Mint 17.1 with absolutely no luck.

First off, I added the Ubuntu tool chain in order to have access to the gcc 6 repositories.

My main issue is when trying to install any of these packages, I get:

Depends: libmpc2 but it is not installable 

Also, apt-get cannot install libmpc2. When I run,

sudo apt-get install libmpc2 

I recieve the following:

Package libmpc2 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source.  E: Package 'libmpc2' has no installation candidate 

I have also tried installing libmpc2 manually using:

dpkg -i <package name>  sudo apt-get install -f ( aptitude install -f as well ) 

Then when I try to install cpp-6 ( which is needed for gcc-6 ), I get the same error, as if it does not know that libmpc2 is there.

Also, why does gcc-6 want libmpc2 and not 3? I know that gcc-4.8.4 uses libmpc3....

But I am currently stuck, so any help would be nice.

Thanks

Replay

Category: linux Time: 2016-07-29 Views: 0

Related post

iOS development

Android development

Python development

JAVA development

Development language

PHP development

Ruby development

search

Front-end development

Database

development tools

Open Platform

Javascript development

.NET development

cloud computing

server

Copyright (C) avrocks.com, All Rights Reserved.

processed in 0.132 (s). 12 q(s)