texlive installation aborted after hours of installation; restarting without duplication

I'm trying to install texlive. I proceeded in the recommended way, as per

After hours since initiating the download with install-tl as per instructions in How to install “vanilla” TeXLive on Debian or Ubuntu?. Hours after intiating the install-tl command, the installation aborted with the following error message:

Installing [2507/3271, time/total: 03:01:18/03:46:09]: rec-thy [221k] TLUtils::check_file: removing /tmp/bgLBEx3xxA/o1ankpQviV/rec-thy.tar.xz, sizes differ: TLUtils::check_file:   TL=0, arg=7428 TLPDB::_install_package: downloading did not succeed Installation failed. Rerunning the installer will try to restart the installation. Or you can restart by running the installer with:   install-tl --profile installation.profile [EXTRA-ARGS] install-tl: Writing log in current directory: /usr/local/src/install-tl-20160728/install-tl.log 

I have no idea how to implement the crypic instruction

install-tl --profile installation.profile [EXTRA-ARGS] 

because I can't find any information as what the EXTRA-ARGS should be, and google provided no help. So I started again with

install-tl 

hoping it would be smart enough not to start from scratch, but it wasn't, and did start from scratch, meaning another 3 hours. This time it crashed after a few minutes, with

Installing [0051/3271, time/total: 04:08/04:30:47]: ae [84k] TLUtils::check_file: removing /tmp/ZLEUeUk8LV/ps7iOTjRWq/ae.tar.xz, sizes differ: TLUtils::check_file:   TL=43160, arg=57364 TLPDB::_install_package: downloading did not succeed Installation failed. Rerunning the installer will try to restart the installation. Or you can restart by running the installer with:   install-tl --profile installation.profile [EXTRA-ARGS] install-tl: Writing log in current directory: /usr/local/src/install-tl-20160728/install-tl.log 

Why would the installation crash at different places? Could somebody please interpret these crashes and how to prevent them? If the installation crashes again, is there a way of picking up where I left off? (presumably using the mysterious EXTRA-ARGS?). If all else fails, is there another way of getting a less complete latex installation that will actually work?

Thanks very much for any advice?

Replay

Just try

sudo install-tl --profile installation.profile

on the command line. Maybe you hit a mirror which wasn't fully synced.

Category: texlive Time: 2016-07-30 Views: 0

Related post

iOS development

Android development

Python development

JAVA development

Development language

PHP development

Ruby development

search

Front-end development

Database

development tools

Open Platform

Javascript development

.NET development

cloud computing

server

Copyright (C) avrocks.com, All Rights Reserved.

processed in 0.246 (s). 12 q(s)