Ubuntu 16.04 does not detect wifi networks

I am having many issues to get Ubuntu 16.04.01 LTS to recognize my wireless card (Intel 3160). I have reinstalled the OS many times, but I have the same problem all the time. A couple of days ago, the first time I installed, it worked, but it just stopped working yesterday, so I decided to reinstall the whole system (repartition included). I have tried many solutions from the forums, but I don't know what else I can do. I love this OS, but I am newby. It would be a pity returning to Windows (I am very tired of Windows, but at least I had wireless connectivity). I have Ethernet connection. Please, keep in mind that I am totally newby, so I don't know how to install a package after downloading it. Thank you in advance for your valuable help!

Edit: Thank you for your quick answer, Pilot6! This is what I am getting:

lspci -knn | grep Net -A2; rfkill list 07:00.0 Network controller [0280]: Intel Corporation Wireless 3160 [8086:08b3] (rev cb)     Subsystem: Intel Corporation Dual Band Wireless AC 3160 [8086:8170]     Kernel driver in use: iwlwifi 0: Toshiba Bluetooth: Bluetooth     Soft blocked: yes     Hard blocked: no 

Edit: this is the output of rfkill list: rfkill list

0: Toshiba Bluetooth: Bluetooth     Soft blocked: no     Hard blocked: no 1: hci0: Bluetooth     Soft blocked: no     Hard blocked: no 

Output of dmesg | grep iwl:

dmesg | grep iwl [    8.059092] iwlwifi 0000:07:00.0: Unsupported splx structure [    8.503267] iwlwifi 0000:07:00.0: Direct firmware load for iwlwifi-3160-17.ucode failed with error -2 [    8.684618] iwlwifi 0000:07:00.0: loaded firmware version 16.242414.0 op_mode iwlmvm [    9.147622] iwlwifi 0000:07:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164 [    9.147949] iwlwifi 0000:07:00.0: L1 Enabled - LTR Enabled [    9.148587] iwlwifi 0000:07:00.0: RF_KILL bit toggled to disable radio. [    9.148607] iwlwifi 0000:07:00.0: L1 Enabled - LTR Enabled [   14.147782] iwlwifi 0000:07:00.0: Failed to load firmware chunk! [   14.147786] iwlwifi 0000:07:00.0: Could not load the [0] uCode section [   14.147792] iwlwifi 0000:07:00.0: Failed to start INIT ucode: -110 [   14.148203] iwlwifi 0000:07:00.0: Failed to run INIT ucode: -110 [   14.148226] iwlwifi 0000:07:00.0: L1 Enabled - LTR Enabled 

Thanks again!

Replay

Category: drivers Time: 2016-07-30 Views: 0

Related post

iOS development

Android development

Python development

JAVA development

Development language

PHP development

Ruby development

search

Front-end development

Database

development tools

Open Platform

Javascript development

.NET development

cloud computing

server

Copyright (C) avrocks.com, All Rights Reserved.

processed in 0.143 (s). 12 q(s)